In breve
- CVE-2024-5798 è una vulnerabilità ALTO (CVSS 7.5) che riguarda github.com/hashicorp/vault, vault (hashicorp).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.34%, superiore al 27.9% delle vulnerabilità.
- Correzione: aggiornare a 1.15.9, 1.16.3, 1.17.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | ≥ 0.11.0, < 1.15.9≥ 0.11.0, < 1.16.3≥ 1.16.0-rc1, < 1.16.3≥ 1.17.0-rc1, < 1.17.0
| 1.15.91.16.31.17.0
|
| vault | ≥ 0.11.0, < 1.15.9≥ 1.16.0, < 1.16.3
| 1.15.91.16.3
|
Description
Vault and Vault Enterprise did not properly validate the JSON Web Token (JWT) role-bound audience claim when using the Vault JWT auth method. This may have resulted in Vault validating a JWT the audience and role-bound claims do not match, allowing an invalid login to succeed when it should have been rejected.
This vulnerability, CVE-2024-5798, was fixed in Vault and Vault Enterprise 1.17.0, 1.16.3, and 1.15.9
NVD description
Vault and Vault Enterprise did not properly validate the JSON Web Token (JWT) role-bound audience claim when using the Vault JWT auth method. This may have resulted in Vault validating a JWT the audience and role-bound claims do not match, allowing an invalid login to succeed when it should have been rejected.
This vulnerability, CVE-2024-5798, was fixed in Vault and Vault Enterprise 1.17.0, 1.16.3, and 1.15.9
Altre vulnerabilità di github.com/hashicorp/vault
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free