In breve
- CVE-2025-10279 è una vulnerabilità ALTO (CVSS 7.0) che riguarda mlflow, mlflow (lfprojects).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.24%, superiore al 15.2% delle vulnerabilità.
- Correzione: aggiornare a 3.4.0rc0, 3.4.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | < 3.4.0rc0
| 3.4.0rc0
|
| mlflow | < 3.4.0
| 3.4.0
|
Description
In mlflow version 2.20.3, the temporary directory used for creating Python virtual environments is assigned insecure world-writable permissions (0o777). This vulnerability allows an attacker with write access to the /tmp directory to exploit a race condition and overwrite .py files in the virtual environment, leading to arbitrary code execution. The issue is resolved in version 3.4.0.
NVD description
In mlflow version 2.20.3, the temporary directory used for creating Python virtual environments is assigned insecure world-writable permissions (0o777). This vulnerability allows an attacker with write access to the `/tmp` directory to exploit a race condition and overwrite `.py` files in the virtual environment, leading to arbitrary code execution. The issue is resolved in version 3.4.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free