In breve
- CVE-2025-27018 è una vulnerabilità MEDIO (CVSS 6.3) che riguarda apache-airflow-providers-mysql, apache-airflow-providers-mysql (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.91%, superiore al 60.0% delle vulnerabilità.
- Correzione: aggiornare a 6.2.0 o successiva.
Description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
NVD description
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Apache Airflow MySQL Provider.
When user triggered a DAG with dump_sql or load_sql functions they could pass a table parameter from a UI, that could cause SQL injection by running SQL that was not intended.
It could lead to data corruption, modification and others.
This issue affects Apache Airflow MySQL Provider: before 6.2.0.
Users are recommended to upgrade to version 6.2.0, which fixes the issue.
Altre vulnerabilità di apache-airflow-providers-mysql
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free