In breve
- CVE-2025-30167 è una vulnerabilità ALTO (CVSS 7.3) che riguarda jupyter-core, jupyter core (jupyter).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.20%, superiore al 9.7% delle vulnerabilità.
- Correzione: aggiornare a 5.8.1, 5.8.0 o successiva.
Description
Impact
On Windows, the shared %PROGRAMDATA% directory is searched for configuration files (SYSTEM_CONFIG_PATH and SYSTEM_JUPYTER_PATH), which may allow users to create configuration files affecting other users.
Only shared Windows systems with multiple users and unprotected %PROGRAMDATA% are affected.
Mitigations
- upgrade to
jupyter_core>=5.8.1 (5.8.0 is patched but breaks jupyter-server) , or
- as administrator, modify the permissions on the
%PROGRAMDATA% directory so it is not writable by unauthorized users, or
- as administrator, create the
%PROGRAMDATA%\jupyter directory with appropriately restrictive permissions, or
- as user or administrator, set the
%PROGRAMDATA% environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators or the current user)
Credit
Reported via Trend Micro Zero Day Initiative as ZDI-CAN-25932
NVD description
Jupyter Core is a package for the core common functionality of Jupyter projects. When using Jupyter Core prior to version 5.8.0 on Windows, the shared `%PROGRAMDATA%` directory is searched for configuration files (`SYSTEM_CONFIG_PATH` and `SYSTEM_JUPYTER_PATH`), which may allow users to create configuration files affecting other users. Only shared Windows systems with multiple users and unprotected `%PROGRAMDATA%` are affected. Users should upgrade to Jupyter Core version 5.8.0 or later to receive a patch. Some other mitigations are available. As administrator, modify the permissions on the `%PROGRAMDATA%` directory so it is not writable by unauthorized users; or as administrator, create the `%PROGRAMDATA%\jupyter` directory with appropriately restrictive permissions; or as user or administrator, set the `%PROGRAMDATA%` environment variable to a directory with appropriately restrictive permissions (e.g. controlled by administrators _or_ the current user).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free