In breve
- CVE-2025-32777 è una vulnerabilità ALTO (CVSS 8.2) che riguarda volcano.sh/volcano.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.48%, superiore al 41.4% delle vulnerabilità.
- Correzione: aggiornare a 1.10.2, 1.11.2, 1.11.0-network-topology-preview.3, 1.12.0-alpha.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| volcano.sh/volcano Go | ≥ 1.10.0-alpha.0, < 1.10.2≥ 1.11.0, < 1.11.2≥ 1.11.0-network-topology-preview.0, < 1.11.0-network-topology-preview.3≥ 1.12.0-alpha.0, < 1.12.0-alpha.2< 1.9.1
| 1.10.21.11.21.11.0-network-topology-preview.31.12.0-alpha.21.9.1
|
Description
Impact
This issue allows an attacker who has compromised either the Elastic service or the extender plugin to cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory.
Workarounds
No
NVD description
Volcano is a Kubernetes-native batch scheduling system. Prior to versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2, attacker compromise of either the Elastic service or the extender plugin can cause denial of service of the scheduler. This is a privilege escalation, because Volcano users may run their Elastic service and extender plugins in separate pods or nodes from the scheduler. In the Kubernetes security model, node isolation is a security boundary, and as such an attacker is able to cross that boundary in Volcano's case if they have compromised either the vulnerable services or the pod/node in which they are deployed. The scheduler will become unavailable to other users and workloads in the cluster. The scheduler will either crash with an unrecoverable OOM panic or freeze while consuming excessive amounts of memory. This issue has been patched in versions 1.11.2, 1.10.2, 1.9.1, 1.11.0-network-topology-preview.3, and 1.12.0-alpha.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free