In breve
- CVE-2025-43863 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda vantage6, vantage6 (vantage6).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.47%, superiore al 40.3% delle vulnerabilità.
- Correzione: aggiornare a 4.11.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| vantage6 PyPI | < 4.11.0
| 4.11.0
|
| vantage6 | < 4.11.0
| 4.11.0
|
Description
Impact
If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct
Patches
This issue has been patched in version 4.11.0
Workarounds
None
NVD description
vantage6 is an open source framework built to enable, manage and deploy privacy enhancing technologies like Federated Learning and Multi-Party Computation. If attacker gets access to an authenticated session, they can try to brute-force the user password by using the change password functionality: they can call that route infinitely which will return the message that password is wrong until it is correct. This vulnerability is fixed in 4.11.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free