In breve
- CVE-2025-50213 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda apache-airflow-providers-snowflake, apache-airflow-providers-snowflake (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.77%, superiore al 55.8% delle vulnerabilità.
- Correzione: aggiornare a 6.4.0 o successiva.
Description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
NVD description
Failure to Sanitize Special Elements into a Different Plane (Special Element Injection) vulnerability in Apache Airflow Providers Snowflake.
This issue affects Apache Airflow Providers Snowflake: before 6.4.0.
Sanitation of table and stage parameters were added in CopyFromExternalStageToSnowflakeOperator to prevent SQL injection
Users are recommended to upgrade to version 6.4.0, which fixes the issue.
Altre vulnerabilità di apache-airflow-providers-snowflake
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free