In breve
- CVE-2025-57809 è una vulnerabilità ALTO (CVSS 7.5) che riguarda xgrammar, xgrammar (mlc-ai).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.48%, superiore al 41.9% delle vulnerabilità.
- Correzione: aggiornare a 0.1.21 o successiva.
| Package | Affected versions | Patched versions |
|---|
| xgrammar PyPI | < 0.1.21
| 0.1.21
|
| xgrammar | < 0.1.21
| 0.1.21
|
Description
Summary
This issue: http://github.com/mlc-ai/xgrammar/issues/250 should have it's own security advisory. Since several tools accept and pass user supplied grammars to xgrammar, and it is so easy to trigger it seems like a High.
NVD description
XGrammar is an open-source library for efficient, flexible, and portable structured generation. Prior to version 0.1.21, XGrammar has an infinite recursion issue in the grammar. This issue has been resolved in version 0.1.21.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free