In breve
- CVE-2025-58352 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda weblate, weblate (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.29%, superiore al 21.6% delle vulnerabilità.
- Correzione: aggiornare a 5.13.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.13.1
| 5.13.1
|
| weblate | < 5.13.1
| 5.13.1
|
Description
Impact
The verification of the second factor had too long a session expiry. The long session expiry could be used to circumvent rate limiting of the second factor.
Patches
This issue has been addressed in Weblate 5.13.1 via https://github.com/WeblateOrg/weblate/pull/16002.
References
Thanks to Nahid Hasan Limon for reporting this issue responsibly.
NVD description
Weblate is a web based localization tool. Versions lower than 5.13.1 contain a vulnerability that causes long session expiry during the second factor verification. The long session expiry could be used to circumvent rate limiting of the second factor. This issue is fixed in version 5.13.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free