In breve
- CVE-2025-59057 è una vulnerabilità ALTO (CVSS 7.6) che riguarda react-router (shopify), remix-run/react (shopify), @remix-run/react.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.50%, superiore al 43.1% delle vulnerabilità.
- Correzione: aggiornare a 2.17.1, 7.9.0 o successiva.
Description
A XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag.
[!NOTE]
This does not impact applications using Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>).
NVD description
React Router is a router for React. In @remix-run/react versions 1.15.0 through 2.17.0. and react-router versions 7.0.0 through 7.8.2, a XSS vulnerability exists in in React Router's meta()/<Meta> APIs in Framework Mode when generating script:ld+json tags which could allow arbitrary JavaScript execution during SSR if untrusted content is used to generate the tag. There is no impact if the application is being used in Declarative Mode (<BrowserRouter>) or Data Mode (createBrowserRouter/<RouterProvider>). This issue has been patched in @remix-run/react version 2.17.1 and react-router version 7.9.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free