In breve
- CVE-2025-59160 è una vulnerabilità BASSO (CVSS 2.7) che riguarda matrix-js-sdk.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.24%, superiore al 15.6% delle vulnerabilità.
- Correzione: aggiornare a 38.2.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| matrix-js-sdk npm | < 38.2.0
| 38.2.0
|
Description
Impact
matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room.
Patches
The issue has been patched and users should upgrade to 38.2.0.
Workarounds
Avoid using MatrixClient::getJoinedRooms in favour of getRooms() and filtering upgraded rooms separately.
NVD description
Matrix JavaScript SDK is a Matrix Client-Server SDK for JavaScript and TypeScript. matrix-js-sdk before 38.2.0 has insufficient validation of room predecessor links in MatrixClient::getJoinedRooms, allowing a remote attacker to attempt to replace a tombstoned room with an unrelated attacker-supplied room. The issue has been patched and users should upgrade to 38.2.0. A workaround is to avoid using MatrixClient::getJoinedRooms in favor of getRooms() and filtering upgraded rooms separately.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free