In breve
- CVE-2025-59328 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda org.apache.fory:fory-core, fory (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.69%, superiore al 52.6% delle vulnerabilità.
- Correzione: aggiornare a 0.12.2 o successiva.
Description
A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users.
Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.
NVD description
A vulnerability in Apache Fory allows a remote attacker to cause a Denial of Service (DoS). The issue stems from the insecure deserialization of untrusted data. An attacker can supply a large, specially crafted data payload that, when processed, consumes an excessive amount of CPU resources during the deserialization process. This leads to CPU exhaustion, rendering the application or system using the Apache Fory library unresponsive and unavailable to legitimate users.
Users of Apache Fory are strongly advised to upgrade to version 0.12.2 or later to mitigate this vulnerability. Developers of libraries and applications that depend on Apache Fory should update their dependency requirements to Apache Fory 0.12.2 or later and release new versions of their software.
Altre vulnerabilità di org.apache.fory:fory-core
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free