In breve
- CVE-2025-6014 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda github.com/hashicorp/vault, vault (hashicorp).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.42%, superiore al 36.0% delle vulnerabilità.
- Correzione: aggiornare a 1.20.1, 1.18.12, 1.19.7, 1.16.23 o successiva.
| Package | Affected versions | Patched versions |
|---|
| github.com/hashicorp/vault Go | < 1.20.1
| 1.20.1
|
| vault | = 1.20.0≥ 1.17.0, < 1.18.12≥ 1.19.0, < 1.19.7< 1.16.23< 1.20.1
| 1.18.121.19.71.16.231.20.1
|
Description
Vault and Vault Enterprise’s (“Vault”) TOTP Secrets Engine code validation endpoint is susceptible to code reuse within its validity period. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
NVD description
Vault and Vault Enterprise’s (“Vault”) TOTP Secrets Engine code validation endpoint is susceptible to code reuse within its validity period. Fixed in Vault Community Edition 1.20.1 and Vault Enterprise 1.20.1, 1.19.7, 1.18.12, and 1.16.23.
Altre vulnerabilità di github.com/hashicorp/vault
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free