| Package | Affected versions | Patched versions |
|---|---|---|
| envoy | = 1.36.0≥ 1.34.0, < 1.34.9≥ 1.35.0, < 1.35.5< 1.33.11 | 1.34.91.35.51.33.11 |
Envoy is a cloud-native, open source edge and service proxy. Prior to 1.36.1, 1.35.5, 1.34.9, and 1.33.10, large requests and responses can potentially trigger TCP connection pool crashes due to flow control management in Envoy. It will happen when the connection is closing but upstream data is still coming, resulting in a buffer watermark callback nullptr reference. The vulnerability impacts TCP proxy and HTTP 1 & 2 mixed use cases based on ALPN. This vulnerability is fixed in 1.36.1, 1.35.5, 1.34.9, and 1.33.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free