In breve
- CVE-2025-64168 è una vulnerabilità ALTO (CVSS 7.1) che riguarda agno.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.16%, superiore al 5.3% delle vulnerabilità.
- Correzione: aggiornare a 2.2.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| agno PyPI | ≥ 2.0.0, < 2.2.2
| 2.2.2
|
Description
Impact
Under certain conditions (under high concurrency), when session_state is passed to an Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user.
Patches
This has been patched in version 2.2.2. Upgrade with pip install -U agno.
NVD description
Agno is a multi-agent framework, runtime and control plane. From 2.0.0 to before 2.2.2, under high concurrency, when session_state is passed to Agent or Team during run or arun calls, a race condition can occur, causing a session_state to be assigned and persisted to the incorrect session. This may result in user data from one session being exposed to another user. This has been patched in version 2.2.2.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free