In breve
- CVE-2025-64718 è una vulnerabilità MEDIO (CVSS 5.3) che riguarda js-yaml (nodeca), js-yaml.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.42%, superiore al 36.6% delle vulnerabilità.
- Correzione: aggiornare a 4.1.1, 3.14.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| js-yaml | ≥ 4.0.0, < 4.1.1< 3.14.2
| 4.1.13.14.2
|
| js-yaml npm | ≥ 4.0.0, < 4.1.1< 3.14.2
| 4.1.13.14.2
|
Description
Impact
In js-yaml 4.1.0, 4.0.0, and 3.14.1 and below, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (__proto__). All users who parse untrusted yaml documents may be impacted.
Patches
Problem is patched in js-yaml 4.1.1 and 3.14.2.
Workarounds
You can protect against this kind of attack on the server by using node --disable-proto=delete or deno (in Deno, pollution protection is on by default).
References
https://cheatsheetseries.owasp.org/cheatsheets/Prototype_Pollution_Prevention_Cheat_Sheet.html
NVD description
js-yaml is a JavaScript YAML parser and dumper. In js-yaml before 4.1.1 and 3.14.2, it's possible for an attacker to modify the prototype of the result of a parsed yaml document via prototype pollution (`__proto__`). All users who parse untrusted yaml documents may be impacted. The problem is patched in js-yaml 4.1.1 and 3.14.2. Users can protect against this kind of attack on the server by using `node --disable-proto=delete` or `deno` (in Deno, pollution protection is on by default).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free