| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.kyuubi:kyuubi-server_2.12 | ≥ 1.6.0, < 1.10.3 | 1.10.3 |
| kyuubi | ≥ 1.6.0, < 1.10.3 | 1.10.3 |
Any client who can access to Apache Kyuubi Server via Kyuubi frontend protocols can bypass server-side config kyuubi.session.local.dir.allow.list and use local files which are not listed in the config.
This issue affects Apache Kyuubi: from 1.6.0 through 1.10.2.
Users are recommended to upgrade to version 1.10.3 or upper, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free