| Package | Affected versions | Patched versions |
|---|---|---|
| discourse | = 2025.12.0≥ 2025.11.0, < 2025.11.2< 3.5.4 | 2025.11.23.5.4 |
Discourse is an open source discussion platform. Versions prior to 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0 have a content-security-policy-mitigated cross-site scriptinv vulnerability on the Discourse Math plugin when using its KaTeX variant. This issue is patched in versions 3.5.4, 2025.11.2, 2025.12.1, and 2026.1.0. As a workaround, the Discourse Math plugin can be disabled, or the Mathjax provider can be used instead of KaTeX.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free