In breve
- CVE-2025-68457 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda orejime (boscop), orejime.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.22%, superiore al 12.4% delle vulnerabilità.
- Correzione: aggiornare a 2.3.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| orejime | < 2.3.2
| 2.3.2
|
| orejime npm | < 2.3.2
| 2.3.2
|
Description
Impact
On HTML elements handled by Orejime, one could run malicious code by embedding javascript: code within data attributes.
When consenting to the related purpose, Orejime would turn data attributes into unprefixed ones (i.e. data-href into href), thus executing the code.
This shouldn't have any impact on most setups, as elements handled by Orejime are generally hardcoded. The problem would only arise if somebody could inject HTML code within pages.
See https://github.com/boscop-fr/orejime/issues/142 for the original report.
Patches
The problem has been patched by https://github.com/boscop-fr/orejime/pull/143. It is available in version 2.3.2.
Workarounds
The problem can be fixed outside of Orejime by sanitizing attributes which could contain executable code.
NVD description
Orejime is a consent manager that focuses on accessibility. On HTML elements handled by Orejime prior to version 2.3.2, one could run malicious code by embedding `javascript:` code within data attributes. When consenting to the related purpose, Orejime would turn data attributes into unprefixed ones (i.e. `data-href` into `href`), thus executing the code. This shouldn't have any impact on most setups, as elements handled by Orejime are generally hardcoded. The problem would only arise if somebody could inject HTML code within pages. The problem has been patched in version 2.3.2. As a workaround, the problem can be fixed outside of Orejime by sanitizing attributes which could contain executable code.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free