In breve
- CVE-2025-7338 è una vulnerabilità ALTO (CVSS 7.5) che riguarda multer.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.81%, superiore al 57.0% delle vulnerabilità.
- Correzione: aggiornare a 2.0.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| multer npm | ≥ 1.4.4-lts.1, < 2.0.2
| 2.0.2
|
Description
Impact
A vulnerability in Multer versions >= 1.4.4-lts.1, < 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed request. This request causes an unhandled exception, leading to a crash of the process.
Patches
Users should upgrade to 2.0.2
Workarounds
None
NVD description
Multer is a node.js middleware for handling `multipart/form-data`. A vulnerability that is present starting in version 1.4.4-lts.1 and prior to version 2.0.2 allows an attacker to trigger a Denial of Service (DoS) by sending a malformed multi-part upload request. This request causes an unhandled exception, leading to a crash of the process. Users should upgrade to version 2.0.2 to receive a patch. No known workarounds are available.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free