In breve
- CVE-2025-8396 è una vulnerabilità MEDIO (CVSS 6.9) che riguarda go.temporal.io/server.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.39%, superiore al 33.1% delle vulnerabilità.
- Correzione: aggiornare a 1.27.3, 1.28.1, 1.26.3 o successiva.
| Package | Affected versions | Patched versions |
|---|
| go.temporal.io/server Go | ≥ 1.27.0-126.0, < 1.27.3≥ 1.28.0-129.0, < 1.28.1< 1.26.3
| 1.27.31.28.11.26.3
|
Description
Insufficiently specific bounds checking on authorization header could lead to denial of service in the Temporal server on all platforms due to excessive memory allocation. This issue affects all platforms and versions of OSS Server prior to 1.26.3, 1.27.3, and 1.28.1 (i.e., fixed in 1.26.3, 1.27.3, and 1.28.1 and later). Temporal Cloud services are not impacted.
NVD description
Insufficiently specific bounds checking on authorization header could lead to denial of service in the Temporal server on all platforms due to excessive memory allocation.This issue affects all platforms and versions of OSS Server prior to 1.26.3, 1.27.3, and 1.28.1 (i.e., fixed in 1.26.3, 1.27.3, and 1.28.1 and later). Temporal Cloud services are not impacted.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free