In breve
- CVE-2026-106456 è una vulnerabilità MEDIO (CVSS 6.5) che riguarda backstage (linuxfoundation), backstage/plugin-proxy-backend (linuxfoundation), @backstage/plugin-proxy-backend.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.24%, superiore al 15.0% delle vulnerabilità.
- Correzione: aggiornare a 1.55.0, 0.6.18 o successiva.
Description
Impact
An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy.
Exploitation requires this specific overlapping route configuration. The resulting confidentiality and integrity impact depends on the capabilities exposed by the nested upstream.
Patches
Upgrade @backstage/plugin-proxy-backend to version 0.6.18 or later. The fixed package is available in Backstage v1.55.0.
Workarounds
- Avoid nesting a credential-protected proxy path below a path configured with
dangerously-allow-unauthenticated.
- Apply the same credential requirement to overlapping proxy paths.
- Restrict direct network access to the Backstage backend until the patched package is deployed.
NVD description
Backstage is an open framework for building developer portals. From 0.5.0 until 0.6.18, the @backstage/plugin-proxy-backend package is affected by inconsistent credential enforcement for overlapping proxy routes. An operator can configure overlapping proxy paths with different credential requirements. When a parent path permits unauthenticated access and a nested path requires credentials, the parent exemption can also cover requests handled by the nested proxy. An unauthenticated caller may therefore reach the nested upstream through Backstage, including with static upstream credentials configured for that proxy. This issue is fixed in version 0.6.18.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free