| Package | Affected versions | Patched versions |
|---|---|---|
| backstage | ≥ 1.47.0, < 1.54.8 | 1.54.8 |
| backstage/plugin-scaffolder-backend-module-sentry | ≥ 0.3.0, < 0.3.8 | 0.3.8 |
| @backstage/plugin-scaffolder-backend-module-sentry | ≥ 0.3.0, < 0.3.8 | 0.3.8 |
An authenticated internal user who can execute the affected actions may cause the backend to contact unintended destinations and disclose Sentry integration credentials. Subsequent impact depends on network reachability and the privileges granted to the configured token.
Upgrade @backstage/plugin-scaffolder-backend-module-sentry to version 0.3.8 or later. The fixed package is available in Backstage v1.54.8 and Backstage v1.55.0.
The update removes custom action-level apiBaseUrl values. Move any such value to scaffolder.sentry.apiBaseUrl before upgrading.
scaffolder.action.execute permission for the affected Sentry actions to trusted users and templates.Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free