In breve
- CVE-2026-11500 è una vulnerabilità MEDIO (CVSS 5.0) che riguarda github.com/weaviate/weaviate.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.34%, superiore al 27.3% delle vulnerabilità.
- Correzione: aggiornare a 1.38.0-rc.0 o successiva.
Description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
NVD description
A vulnerability was identified in Weaviate up to 1.37.7. This vulnerability affects the function validateConfig of the file usecases/auth/authentication/apikey/client.go of the component Static API Key Handler. The manipulation of the argument StaticApiKey leads to authorization bypass. It is possible to initiate the attack remotely. The complexity of an attack is rather high. It is stated that the exploitability is difficult. The exploit is publicly available and might be used. Upgrading to version 1.38.0-rc.0 is able to resolve this issue. The identifier of the patch is 40f2cc32279f0f8a51016c3c6870a2c0c808e6c0. You should upgrade the affected component.
Altre vulnerabilità di github.com/weaviate/weaviate
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free