In breve
- CVE-2026-12151 è una vulnerabilità ALTO (CVSS 7.5) che riguarda undici (nodejs), undici.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.79%, superiore al 56.2% delle vulnerabilità.
- Correzione: aggiornare a 6.27.0, 7.28.0, 8.5.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| undici | ≥ 6.17.0, < 6.27.0≥ 7.0.0, < 7.28.0≥ 8.0.0, < 8.5.0
| 6.27.07.28.08.5.0
|
| undici npm | ≥ 7.0.0, < 7.28.0≥ 8.0.0, < 8.5.0< 6.27.0
| 7.28.08.5.06.27.0
|
Description
Impact
The undici WebSocket client enforces maxPayloadSize on the cumulative byte count of fragments in a message but does not enforce a limit on the number of fragments. A malicious WebSocket server can stream many small or empty continuation frames that each pass per-frame and cumulative-size validation, collectively causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service.
Affected applications are those using the undici WebSocket client (new WebSocket(...)) or the WebSocketStream API that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint.
All releases starting at undici 6.17.0 are affected.
Patches
Upgrade to undici v6.27.0, v7.28.0 or v8.5.0.
Workarounds
No workaround is available. The fix must be applied through an upgrade.
NVD description
Impact:
The undici WebSocket client enforces maxPayloadSize on the cumulative byte count of fragments in a message but does not enforce a limit on the number of fragments. A malicious WebSocket server can stream many small or empty continuation frames that each pass per-frame and cumulative-size validation, collectively causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service.
Affected applications are those using the undici WebSocket client (new WebSocket(...)) or the WebSocketStream API that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint.
All releases starting at undici 6.17.0 are affected.
Patches: Upgrade to undici >= 6.26.0, >= 7.28.0, or >= 8.5.0. Workarounds:
No workaround is available. The fix must be applied through an upgrade.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free