In breve
- CVE-2026-24013 è una vulnerabilità CRITICO (CVSS 9.1) che riguarda apache-iotdb, iotdb (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.64%, superiore al 50.5% delle vulnerabilità.
- Correzione: aggiornare a 2.0.8 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-iotdb PyPI | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
| iotdb | ≥ 1.3.3, < 2.0.8
| 2.0.8
|
Description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
NVD description
Authentication Bypass by Spoofing vulnerability in Apache IoTDB.
Certain Thrift RPC query handlers lack strict validation of the sessionId
parameter. An attacker can construct requests with a forged sessionId and,
without performing openSession authentication, receive valid query results.
This allows authentication bypass and unauthorized reading of time-series
data.
This issue affects Apache IoTDB: from 1.3.3 before 2.0.8.
Users are recommended to upgrade to version 2.0.8, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free