In breve
- CVE-2026-24906 è una vulnerabilità MEDIO (CVSS 5.4) che riguarda october/system, october (octobercms).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.25%, superiore al 16.7% delle vulnerabilità.
- Correzione: aggiornare a 4.1.10, 3.7.14 o successiva.
| Package | Affected versions | Patched versions |
|---|
| october/system Packagist | ≥ 4.0.0, < 4.1.10< 3.7.14
| 4.1.103.7.14
|
| october | ≥ 4.0.0, ≤ 4.1.9≤ 3.7.13
| No fix yet |
Description
A stored cross-site scripting (XSS) vulnerability was identified in the Backend Editor Settings. The Markup Classes fields (used for paragraph styles, inline styles, table styles, etc.) did not sanitize input to valid CSS class name characters. Malicious values were rendered unsanitized in Froala editor dropdown menus, allowing JavaScript execution when any user opened a RichEditor.
Impact
- Stored XSS via editor settings rendered in RichEditor dropdowns
- Could allow privilege escalation if a superuser opens any RichEditor (e.g., editing a blog post)
- Requires authenticated backend access with editor settings permissions
- Triggers on routine content editing operations
Patches
The vulnerability has been patched in v3.7.14 and v4.1.10. All users are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Restrict editor settings permissions to fully trusted administrators only
References
NVD description
October is a Content Management System (CMS) and web platform. Versions prior to 3.7.14 and 4.1.10 contain a Stored Cross-Site Scripting (XSS) vulnerability in the Backend Editor Settings. The Markup Classes fields (used for paragraph styles, inline styles, table styles, etc.) did not sanitize input to valid CSS class name characters. Malicious values were rendered unsanitized in Froala editor dropdown menus, allowing JavaScript execution when any user opened a RichEditor. Exploitation could lead to privilege escalation if a superuser opens any RichEditor during routine content editing (e.g., editing a blog post), and requires authenticated backend access with editor settings permissions. This issue has been fixed in versions 3.7.14 and 4.1.10. To workaround this issue, restrict editor settings permissions to fully trusted administrators only
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free