In breve
- CVE-2026-2611 è una vulnerabilità CRITICO (CVSS 9.6) che riguarda mlflow, mlflow (lfprojects).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.38%, superiore al 32.5% delle vulnerabilità.
- Correzione: aggiornare a 3.10.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| mlflow PyPI | ≥ 3.9.0, < 3.10.0
| 3.10.0
|
| mlflow | ≥ 3.9.0, < 3.10.0
| 3.10.0
|
Description
In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.
NVD description
In MLflow version 3.9.0, the MLflow Assistant feature introduced improper origin validation in its /ajax-api endpoints. This vulnerability allows a remote attacker to exploit cross-origin requests from a malicious webpage to interact with the MLflow Assistant running on a victim's local machine. By bypassing the loopback-only restriction, the attacker can modify the Assistant's configuration to enable full access, which in turn allows the execution of arbitrary commands via the Claude Code sub-agent. This issue is resolved in version 3.10.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free