In breve
- CVE-2026-26274 è una vulnerabilità MEDIO (CVSS 6.6) che riguarda october/october.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.23%, superiore al 13.8% delle vulnerabilità.
- Correzione: aggiornare a 4.1.10, 3.7.14 o successiva.
| Package | Affected versions | Patched versions |
|---|
| october/october Packagist | ≥ 4.0.0, < 4.1.10< 3.7.14
| 4.1.103.7.14
|
Description
A vulnerability was identified in the Twig sandbox security policy that allowed database write operations when cms.safe_mode is enabled. Backend users with Developer permissions could use Twig template markup to execute insert, update, and delete operations on any database table through the query builder, which is included in the sandbox allow-list.
Impact
- Arbitrary database writes including modification or deletion of any table
- Requires authenticated backend access with Developer permissions
- Only relevant when
cms.safe_mode is enabled (otherwise direct PHP injection is already possible)
Patches
The vulnerability has been patched in v3.7.14 and v4.1.10. Write operations such as insert, update, delete, and truncate are now blocked on query builder and model objects within the Twig sandbox. All users are encouraged to upgrade to the latest patched version.
Workarounds
If upgrading immediately is not possible:
- Restrict Developer tool access to fully trusted administrators only
Reporter
NVD description
October is a Content Management System (CMS) and web platform. Prior to 3.7.14 and 4.1.10, a vulnerability was identified in the Twig sandbox security policy that allowed database write operations when cms.safe_mode is enabled. Backend users with Developer permissions could use Twig template markup to execute insert, update, and delete operations on any database table through the query builder, which is included in the sandbox allow-list. This vulnerability is fixed in 3.7.14 and 4.1.10.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free