In breve
- CVE-2026-27628 è una vulnerabilità ALTO (CVSS 7.5) che riguarda pypdf, pypdf (pypdf project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.40%, superiore al 33.9% delle vulnerabilità.
- Correzione: aggiornare a 6.7.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.7.2
| 6.7.2
|
| pypdf | < 6.7.2
| 6.7.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file.
Patches
This has been fixed in pypdf==6.7.2.
Workarounds
If users cannot upgrade yet, consider applying the changes from PR #3655.
NVD description
pypdf is a free and open-source pure-python PDF library. Prior to 6.7.2, an attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading the file. This has been fixed in pypdf 6.7.2. As a workaround, one may apply the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free