In breve
- CVE-2026-28563 è una vulnerabilità MEDIO (CVSS 4.3) che riguarda apache-airflow, airflow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.46%, superiore al 39.6% delle vulnerabilità.
- Correzione: aggiornare a 3.1.8 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
| airflow | ≥ 3.0.0, < 3.1.8
| 3.1.8
|
Description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
NVD description
Apache Airflow versions 3.1.0 through 3.1.7 /ui/dependencies endpoint returns the full DAG dependency graph without filtering by authorized DAG IDs. This allows an authenticated user with only DAG Dependencies permission to enumerate DAGs they are not authorized to view.
Users are recommended to upgrade to Apache Airflow 3.1.8 or later, which resolves this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free