In breve
- CVE-2026-29793 è una vulnerabilità CRITICO (CVSS 9.8) che riguarda feathers (feathersjs), @feathersjs/mongodb.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.48%, superiore al 41.4% delle vulnerabilità.
- Correzione: aggiornare a 5.0.42 o successiva.
Description
Socket.IO clients can send arbitrary JavaScript objects as the id argument to any service method (get, patch, update, remove). The transport layer performs no type checking on this argument. When the service uses the MongoDB adapter, these objects pass through getObjectId() and land directly in the MongoDB query as operators. Sending {$ne: null} as the id matches every document in the collection.
NVD description
Feathersjs is a framework for creating web APIs and real-time applications with TypeScript or JavaScript. From 5.0.0 to before 5.0.42, Socket.IO clients can send arbitrary JavaScript objects as the id argument to any service method (get, patch, update, remove). The transport layer performs no type checking on this argument. When the service uses the MongoDB adapter, these objects pass through getObjectId() and land directly in the MongoDB query as operators. Sending {$ne: null} as the id matches every document in the collection. This vulnerability is fixed in 5.0.42.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free