In breve
- CVE-2026-30226 è una vulnerabilità ALTO (CVSS 7.5) che riguarda devalue (svelte), devalue.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.42%, superiore al 36.0% delle vulnerabilità.
- Correzione: aggiornare a 5.6.4 o successiva.
| Package | Affected versions | Patched versions |
|---|
| devalue | < 5.6.4
| 5.6.4
|
| devalue npm | < 5.6.4
| 5.6.4
|
Description
In devalue v5.6.3, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion.
NVD description
Svelte devalue is a JavaScript library that serializes values into strings when JSON.stringify isn't sufficient for the job. In devalue v5.6.3 and earlier, devalue.parse and devalue.unflatten were susceptible to prototype pollution via maliciously crafted payloads. Successful exploitation could lead to Denial of Service (DoS) or type confusion. This vulnerability is fixed in 5.6.4.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free