In breve
- CVE-2026-30938 è una vulnerabilità MEDIO (CVSS 5.3) che riguarda parse-server (parseplatform), parse-server.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.42%, superiore al 36.1% delle vulnerabilità.
- Correzione: aggiornare a 9.5.1, 8.6.12, 9.5.1-alpha.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| parse-server | ≥ 9.0.0, < 9.5.1< 8.6.12
| 9.5.18.6.12
|
| parse-server npm | ≥ 9.0.0-alpha.1, < 9.5.1-alpha.1< 8.6.12
| 9.5.1-alpha.18.6.12
|
Description
Impact
The requestKeywordDenylist security control can be bypassed by placing any nested object or array before a prohibited keyword in the request payload. This is caused by a logic bug that stops scanning sibling keys after encountering the first nested value. Any custom requestKeywordDenylist entries configured by the developer are equally by-passable using the same technique.
All Parse Server deployments are affected. The requestKeywordDenylist is enabled by default.
Patches
The fix replaces the recursive object scanner with an iterative stack-based traversal that processes all nested values without prematurely exiting the scan loop. This also eliminates a potential stack overflow on deeply nested payloads.
Workarounds
Use a Cloud Code beforeSave trigger to validate incoming data for prohibited keywords across all classes.
References
NVD description
Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 8.6.12 and 9.5.1-alpha.1, the requestKeywordDenylist security control can be bypassed by placing any nested object or array before a prohibited keyword in the request payload. This is caused by a logic bug that stops scanning sibling keys after encountering the first nested value. Any custom requestKeywordDenylist entries configured by the developer are equally by-passable using the same technique. All Parse Server deployments are affected. The requestKeywordDenylist is enabled by default. This vulnerability is fixed in 8.6.12 and 9.5.1-alpha.1. Use a Cloud Code beforeSave trigger to validate incoming data for prohibited keywords across all classes.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free