In breve
- CVE-2026-31987 è una vulnerabilità ALTO (CVSS 7.5) che riguarda apache-airflow, airflow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.74%, superiore al 54.6% delle vulnerabilità.
- Correzione: aggiornare a 3.2.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
| airflow | ≥ 3.0.0, < 3.2.0
| 3.2.0
|
Description
JWT Tokens used by tasks were exposed in logs. This could allow UI users to act as Dag Authors.
Users are advised to upgrade to Airflow version that contains fix.
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
NVD description
JWT Tokens used by tasks were exposed in logs. This could allow UI users to act as Dag Authors.
Users are advised to upgrade to Airflow version that contains fix.
Users are recommended to upgrade to version 3.2.0, which fixes this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free