In breve
- CVE-2026-33212 è una vulnerabilità BASSO (CVSS 3.1) che riguarda weblate, weblate (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.22%, superiore al 12.7% delle vulnerabilità.
- Correzione: aggiornare a 5.17 o successiva.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
The API for tasks didn't verify user access for pending tasks. This could expose logs of in-progress operations to users who don't have access to given scope.
Patches
Workarounds
The attacker needs to guess the random UUID of the task, so exploiting this is unlikely with the default API rate limits.
References
This issue was identified by Michal Čihař.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, the tasks API didn't verify user access for pending tasks. This could expose logs of in-progress operations to users who don't have access to given scope. The attacker needs to brute-force the random UUID of the task, so exploiting this is unlikely with the default API rate limits. This issue has been fixed in version 5.17.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free