In breve
- CVE-2026-33660 è una vulnerabilità ALTO (CVSS 8.8) che riguarda n8n (n8n), n8n.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.97%, superiore al 61.9% delle vulnerabilità.
- Correzione: aggiornare a 2.13.3, 1.123.27, 2.14.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| n8n | = 2.14.0≥ 2.0.0, < 2.13.3< 1.123.27
| 2.13.31.123.27
|
| n8n npm | ≥ 2.0.0-rc.0, < 2.13.3≥ 2.14.0, < 2.14.1< 1.123.27
| 2.13.32.14.11.123.27
|
Description
Impact
An authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the intance.
Patches
The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.27. Users should upgrade to one of these versions or later to remediate the vulnerability.
Workarounds
If upgrading is not immediately possible, administrators should consider the following temporary mitigations:
- Limit workflow creation and editing permissions to fully trusted users only.
- Disable the Merge node by adding
n8n-nodes-base.merge to the NODES_EXCLUDE environment variable.
These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
NVD description
n8n is an open source workflow automation platform. Prior to versions 2.14.1, 2.13.3, and 1.123.26, an authenticated user with permission to create or modify workflows could use the Merge node's "Combine by SQL" mode to read local files on the n8n host and achieve remote code execution. The AlaSQL sandbox did not sufficiently restrict certain SQL statements, allowing an attacker to access sensitive files on the server or even compromise the instance. The issue has been fixed in n8n versions 2.14.1, 2.13.3, and 1.123.26. Users should upgrade to one of these versions or later to remediate the vulnerability. If upgrading is not immediately possible, administrators should consider the following temporary mitigations: Limit workflow creation and editing permissions to fully trusted users only, and/or disable the Merge node by adding `n8n-nodes-base.merge` to the `NODES_EXCLUDE` environment variable. These workarounds do not fully remediate the risk and should only be used as short-term mitigation measures.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free