In breve
- CVE-2026-33699 è una vulnerabilità ALTO (CVSS 7.5) che riguarda pypdf, pypdf (pypdf project).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.47%, superiore al 40.9% delle vulnerabilità.
- Correzione: aggiornare a 6.9.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| pypdf PyPI | < 6.9.2
| 6.9.2
|
| pypdf | < 6.9.2
| 6.9.2
|
Description
Impact
An attacker who uses this vulnerability can craft a PDF which leads to an infinite loop. This requires reading a file in non-strict mode.
Patches
This has been fixed in pypdf==6.9.2.
Workarounds
If users cannot upgrade yet, consider applying the changes from PR #3693.
NVD description
pypdf is a free and open-source pure-python PDF library. Versions prior to 6.9.2 have a vulnerability in which an attacker can craft a PDF which leads to an infinite loop. This requires reading a file in non-strict mode. This has been fixed in pypdf 6.9.2. If users cannot upgrade yet, consider applying the changes from the patch manually.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free