In breve
- CVE-2026-33858 è una vulnerabilità ALTO (CVSS 8.8) che riguarda apache-airflow, airflow (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.59%, superiore al 48.3% delle vulnerabilità.
- Correzione: aggiornare a 3.2.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| apache-airflow PyPI | ≥ 3.1.8, < 3.2.0
| 3.2.0
|
| airflow | ≥ 3.1.8, < 3.2.0
| 3.2.0
|
Description
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.
Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.
NVD description
Dag Authors, who normally should not be able to execute code in the webserver context could craft XCom payload causing the webserver to execute arbitrary code. Since Dag Authors are already highly trusted, severity of this issue is Low.
Users are recommended to upgrade to Apache Airflow 3.2.0, which resolves this issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free