In breve
- CVE-2026-34052 è una vulnerabilità MEDIO (CVSS 5.9) che riguarda jupyterhub-ltiauthenticator, lti jupyterhub authenticator (jupyter).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.34%, superiore al 27.7% delle vulnerabilità.
- Correzione: aggiornare a 1.6.3 o successiva.
Description
Summary
The LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service.
Patches
- upgrade jupyterhub-litauthenticator to 1.6.3
NVD description
LTI JupyterHub Authenticator is a JupyterHub authenticator for LTI. Prior to version 1.6.3, the LTI 1.1 validator stores OAuth nonces in a class-level dictionary that grows without bounds. Nonces are added before signature validation, so an attacker with knowledge of a valid consumer key can send repeated requests with unique nonces to gradually exhaust server memory, causing a denial of service. This issue has been patched in version 1.6.3.
Altre vulnerabilità di jupyterhub-ltiauthenticator
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free