In breve
- CVE-2026-34242 è una vulnerabilità ALTO (CVSS 7.7) che riguarda weblate, weblate (weblate).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.46%, superiore al 40.3% delle vulnerabilità.
- Correzione: aggiornare a 5.17 o successiva.
| Package | Affected versions | Patched versions |
|---|
| weblate PyPI | < 5.17
| 5.17
|
| weblate | < 5.17
| 5.17
|
Description
Impact
The ZIP download feature didn't verify downloaded file and it could follow symlinks outside the repository.
Patches
References
Thanks to @DavidCarliez for reporting this vulnerability via GitHub.
NVD description
Weblate is a web based localization tool. In versions prior to 5.17, the ZIP download feature didn't verify downloaded files, potentially following symlinks outside the repository. This issue has been fixed in version 5.17.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free