In breve
- CVE-2026-35029 è una vulnerabilità ALTO (CVSS 8.8) che riguarda litellm, litellm (litellm).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 38.6%, superiore al 98.6% delle vulnerabilità.
- Correzione: aggiornare a 1.83.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| litellm PyPI | < 1.83.0
| 1.83.0
|
| litellm | < 1.83.0
| 1.83.0
|
Description
Impact
The /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to do the following:
- Modify proxy configuration and environment variables
- Register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution
- Read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image
- Take over other priveleged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables
Patches
Fixed in v1.83.0. The endpoint now requires proxy_admin role.
Workarounds
Restrict API key distribution. There is no configuration-level workaround.
NVD description
LiteLLM is a proxy server (AI Gateway) to call LLM APIs in OpenAI (or native) format. Prior to 1.83.0, the /config/update endpoint does not enforce admin role authorization. A user who is already authenticated into the platform can then use this endpoint to modify proxy configuration and environment variables, register custom pass-through endpoint handlers pointing to attacker-controlled Python code, achieving remote code execution, read arbitrary server files by setting UI_LOGO_PATH and fetching via /get_image, and take over other privileged accounts by overwriting UI_USERNAME and UI_PASSWORD environment variables. Fixed in v1.83.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free