In breve
- CVE-2026-39847 è una vulnerabilità ALTO (CVSS 7.5) che riguarda emmett, emmett (emmett).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.51%, superiore al 44.0% delle vulnerabilità.
- Correzione: aggiornare a 2.8.1 o successiva.
| Package | Affected versions | Patched versions |
|---|
| emmett PyPI | ≥ 2.5.0, < 2.8.1
| 2.8.1
|
| emmett | ≥ 2.5.0, < 2.8.1
| 2.8.1
|
Description
The RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path traversal attacks.
An attacker can use ../ sequences (eg /__emmett__/../rsgi/handlers.py) to read arbitrary files outside the assets directory.
NVD description
Emmett is a full-stack Python web framework designed with simplicity. From 2.5.0 to before 2.8.1, the RSGI static handler for Emmett's internal assets (/__emmett__ paths) is vulnerable to path traversal attacks. An attacker can use ../ sequences (eg /__emmett__/../rsgi/handlers.py) to read arbitrary files outside the assets directory. This vulnerability is fixed in 2.8.1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free