In breve
- CVE-2026-4092 è una vulnerabilità ALTO (CVSS 8.8) che riguarda clasp (google), @google/clasp.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.47%, superiore al 41.1% delle vulnerabilità.
- Correzione: aggiornare a 3.2.0 o successiva.
Description
Impact
Allows an attacker to perform a "Path Traversal" attack to modify files outside the projects directory, potentially allowing for running attacker code on the developer's machine.
Patches
Fixed in version 3.2.0
Workarounds
- Only clone or pull scripts from trusted sources
- Review the output of the
pull and clone commands to verify only expected project files are modified
NVD description
Path Traversal in Clasp impacting versions < 3.2.0 allows a remote attacker to perform remote code execution via a malicious Google Apps Script project containing specially crafted filenames with directory traversal sequences.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free