| Package | Affected versions | Patched versions |
|---|---|---|
| org.springframework.ai:spring-ai-transformers | ≥ 1.0.0, < 1.0.6≥ 1.1.0, < 1.1.5 | 1.0.61.1.5 |
| spring ai | ≥ 1.0.0, < 1.0.6≥ 1.1.0, < 1.1.5 | 1.0.61.1.5 |
In Spring AI, having access to a shared environment can expose the ONNX model used by the application.
Affected versions: Spring AI: 1.0.0 - 1.0.5 (fixed in 1.0.6), 1.1.0 - 1.1.4 (fixed in 1.1.5)
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free