In breve
- CVE-2026-42280 è una vulnerabilità ALTO (CVSS 7.1) che riguarda auth0.js (auth0), auth0-js.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.21%, superiore al 11.4% delle vulnerabilità.
- Correzione: aggiornare a 10.0.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| auth0.js | ≥ 8.11.0, < 10.0.0
| 10.0.0
|
| auth0-js npm | ≥ 8.11.0, < 10.0.0
| 10.0.0
|
Description
Description
Under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided.
Am I Affected?
Users are affected if they meet each of the following preconditions:
- Applications built using Auth0.js version between 8.11.0 and 9.32.0
- The application’s access control relies on rules defined in Auth0 Actions.
Affected product and versions
auth0.js SDK v8.11.0 to v9.32.0
Resolution
Upgrade auth0/auth0.js to v10.0.0 or greater.
Acknowledgements
Okta would like to thank Quan Le (@aleister1102) for their discovery and responsible disclosure.
NVD description
Auth0.js is a client-side JavaScript library for Auth0. From 8.11.0 to 9.32.0, under specific preconditions, the Auth0.js SDK may improperly return user profile information using a valid access token when a specifically crafted invalid ID token is provided. This vulnerability is fixed in 10.0.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free