In breve
- CVE-2026-42509 è una vulnerabilità MEDIO (CVSS 6.1) che riguarda org.apache.wicket:wicket-parent, wicket (apache).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.36%, superiore al 29.4% delle vulnerabilità.
- Correzione: aggiornare a 10.9.0 o successiva.
| Package | Affected versions | Patched versions |
|---|
| org.apache.wicket:wicket-parent Maven | ≥ 10.0.0-M1, < 10.9.0≥ 8.0.0-M1, ≤ 8.17.0≥ 9.0.0-M1, ≤ 9.22.0
| 10.9.0
|
| wicket | ≥ 10.0.0, < 10.9.0≥ 8.0.0, ≤ 8.17.0≥ 9.0.0, ≤ 9.22.0
| 10.9.0
|
Description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
NVD description
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Apache Wicket.
This issue affects Apache Wicket: from 8.0.0 through 8.17.0, 9.0.0, from 10.0.0 through 10.8.0.
Users are recommended to upgrade to version 10.9.0, which fixes the issue.
Altre vulnerabilità di org.apache.wicket:wicket-parent
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free