| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.activemq:apache-activemq | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
| activemq | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
| activemq broker | ≥ 6.0.0, < 6.2.6< 5.19.7 | 6.2.65.19.7 |
Incomplete authorization by Apache ActiveMQ server before versions v6.2.6 and v5.19.7 allows authenticated connections to remove existing destinations with proper permissions.
This issue affects Apache ActiveMQ Broker: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ All: before 5.19.7, from 6.0.0 before 6.2.6; Apache ActiveMQ: before 5.19.7, from 6.0.0 before 6.2.6.
Users are recommended to upgrade to version v6.2.6 or v5.19.7, which fixes the issue.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free