In breve
- CVE-2026-5079 è una vulnerabilità ALTO (CVSS 7.5) che riguarda multer (expressjs), multer.
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.28%, superiore al 20.5% delle vulnerabilità.
- Correzione: aggiornare a 2.2.0, 3.0.0-alpha.2 o successiva.
| Package | Affected versions | Patched versions |
|---|
| multer | = 3.0.0≥ 1.0.0, < 2.2.0
| 2.2.0
|
| multer npm | ≥ 1.0.0, < 2.2.0≥ 3.0.0-alpha.1, < 3.0.0-alpha.2
| 2.2.03.0.0-alpha.2
|
Description
Impact
Multer is vulnerable to a Denial of Service (DoS) via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names (e.g., a[b][c]) with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.
Patches
Users should upgrade to 2.2.0 and configure limits.fieldNestingDepth to the minimum depth their application requires.
Workarounds
Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
NVD description
Impact: multer versions 1.0.0 through 2.1.1 and 3.0.0-alpha.1 are vulnerable to a Denial of Service via deeply nested field names in multipart form data. The append-field dependency parses bracket notation in field names with no limit on nesting depth, allowing an attacker to force allocation of deeply nested object structures that consume CPU and memory. A single HTTP request with a crafted multipart body is sufficient to exploit this.
Patches: Users should upgrade to multer 2.2.0 (2.x line) or 3.0.0-alpha.2 (3.x prerelease) and configure the new limits.fieldNestingDepth option to the minimum depth their application requires.
Workarounds: Set limits.fields to a reasonable value to reduce the number of fields an attacker can send per request. This does not fully mitigate the issue but limits the impact.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free