In breve
- CVE-2026-55170 è una vulnerabilità MEDIO (CVSS 5.4) che riguarda github.com/openfga/openfga, helm charts (openfga), openfga (openfga).
- Probabilità di sfruttamento nei prossimi 30 giorni (EPSS): 0.34%, superiore al 27.4% delle vulnerabilità.
- Correzione: aggiornare a 1.18.0, 0.3.9 o successiva.
Description
Description
In OpenFGA, when MySQL is being used as the datastore, two distinct check requests can return the same response.
Preconditions
This applies if the following preconditions are met:
- You run OpenFGA with MySQL as the datastore
- Your authorization decisions rely on case-sensitive user strings.
Fix
Upgrade to OpenFGA 1.18.0 or greater.
Acknowledgements
OpenFGA would like to thank @sahajamoth for the detailed report.
NVD description
OpenFGA is an authorization/permission engine built for developers. Prior to 1.18.0, when MySQL is being used as the datastore and authorization decisions rely on case-sensitive user strings, the tuple, changelog, and authorization_model identifier columns can compare case-distinct values such as user:Alice and user:alice as equivalent, causing two distinct check requests to return the same response. This issue is fixed in 1.18.0.
Altre vulnerabilità di github.com/openfga/openfga
Vedi tutto →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free